Back to overview
Degraded

Whatfix Platform Performance Degradation

Mar 02 at 04:38pm IST

Resolved
Mar 02 at 04:40pm IST

We have now resolved

Updated
Mar 02 at 04:39pm IST

We have identified issue and are implementing a fix

Created
Mar 02 at 04:38pm IST

We are investigating the issue