Back to overview
Degraded

Test report

Jan 30 at 12:00pm IST
Affected services
Whatfix.com

Resolved
Jan 30 at 06:00pm IST

Testing 234

Created
Jan 30 at 12:00pm IST

Testing 123