Back to overview
Downtime
test4
Mar 16 at 03:40pm IST
Affected services
Whatfix.com
North America - Web Deployment
Resolved
Mar 17 at 03:41pm IST
resolved
Affected services
Whatfix.com
North America - Web Deployment
Created
Mar 16 at 03:40pm IST
down and degraded
Affected services
Whatfix.com
North America - Web Deployment