Back to overview
Degraded

Dashboard loading issue

May 14 at 09:49pm IST
Affected services
Dashboard

Resolved
May 14 at 09:57pm IST

The dashboard loading issue has been resolved. All services are now operating normally.

Created
May 14 at 09:49pm IST

We are currently experiencing an issue where dashboards are not loading as expected. Our team is actively investigating the root cause and working on a fix.